Vestra - Updating to V4 Panel, Welcome back Vestra! – Incident details

Updating to V4 Panel, Welcome back Vestra!

Resolved
Under maintenance
Started 5 months agoLasted 11 days

Affected

Website

Under maintenance from 10:18 PM to 3:33 PM

Game Panel/Billing Panel

Under maintenance from 10:18 PM to 3:33 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.